Intermittent Latency for Status Pages

Incident Report for Rootly Production

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 08:58 PDT

Investigating

We're investigating user reports of public status pages not loading.
Posted Apr 02, 2025 - 08:34 PDT
This incident affected: Rootly Status Page.