All regions are showing healthy traffic and all products are working as expected. We will continue to monitor out of precaution.
Posted Nov 18, 2025 - 05:58 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 05:44 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 05:42 PST
Update
We are seeing degraded affects across several regions still for some users. We are continuing to monitor. Cloudflare has identified the issue and implementing a fix: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7.
Posted Nov 18, 2025 - 05:37 PST
Update
We are seeing degraded affects across several regions still for some users (some with stronger recovery than others). We are continuing to monitor.
Posted Nov 18, 2025 - 05:19 PST
Update
We are seeing degraded affects across several regions still for some users. We are continuing to monitor.
Posted Nov 18, 2025 - 04:49 PST
Monitoring
We are seeing strong recovery across most regions (NA, EMEA, APAC, etc.). Everything appears to be functioning as expected for most users (some still require retries and is intermittent). We are continuing to monitor. https://www.cloudflarestatus.com/incidents/8gmgl950y3h7