Investigating Search Latency

Incident Report for Rootly Production

Resolved

This incident has been resolved.
Posted Sep 25, 2025 - 14:13 PDT

Monitoring

We identified the root cause of the issue and have implemented a fix.

Latencies have returned to normal and we are monitoring them going forward.
Posted Sep 25, 2025 - 09:49 PDT

Investigating

We are currently investigating increased latency in our in-app search (including alert search and incident search).

Newly created resources may not be immediately searchable.

Search results in-app may be slower to load than normal.

Search results may be returned more slowly for certain API endpoints, including: GET /api/v1/incidents, GET /api/v1/services, GET /api/v1/groups, GET /api/v1/users, and GET /api/v1/audits.

Our team is actively working on resolving this issue and will provide updates as soon as more information becomes available.
Posted Sep 25, 2025 - 09:16 PDT
This incident affected: Web Platform and API.