Investigating Increased Latency

Incident Report for Rootly Production

Resolved

We have fully resolved the latency issues that were affecting our service. All systems are should now be operating normally, and performance has returned to expected levels.
Posted Oct 29, 2025 - 14:40 PDT

Identified

We've identified the issue and are working to towards mitigation.
Posted Oct 29, 2025 - 14:10 PDT

Investigating

We are currently investigating reports of increased latency across the Rootly platform. Users may experience slower-than-usual response times when performing actions.

At this time, paging and alerting are not impacted, and all core functionality remains operational.

Our engineering team is actively working to identify and mitigate the cause. We will provide updates as more information becomes available.
Posted Oct 29, 2025 - 13:32 PDT
This incident affected: Slack App, Web Platform, Mobile App, and API.