Slack Performance Degradation (Upstream Issue)

Incident Report for Rootly Production

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 21:39 PST

Identified

It appears Slack has identified the issue and is implementing a fix. We are continuing to monitor here: https://slack-status.com/2025-11/66f5fbbfdb8d6f73.
Posted Nov 06, 2025 - 19:14 PST

Investigating

We’re currently observing degraded Slack performance due to an upstream issue with Slack. You can follow updates directly from Slack here: https://slack-status.com/2025-11/66f5fbbfdb8d6f73
Posted Nov 06, 2025 - 18:32 PST
This incident affected: Slack App.