Web and Desktop Slack Client not populating select/multi-select menus

Incident Report for Rootly Production

Resolved

This issue is resolved.

A hard refresh of Slack's web client, or desktop client using Command + Shift + R (Mac) or Ctrl + Shift + R (Windows/Linux) may be required to restore select and multi-select form functionality.
Posted Jul 15, 2025 - 12:29 PDT

Monitoring

We are seeing reports that updating Slack Desktop Client to version Version 4.45.60
a8def85020f2e6f981e24e9ee2c4f8582820e1e7@1752601050 (Production) may resolve this issue.

Please continue trying to refresh desktop client using Command + Shift + R (Mac) or Ctrl + Shift + R (Windows/Linux).

We will continue to monitor this issue.
Posted Jul 15, 2025 - 12:01 PDT

Update

Slack continues to work toward resolving this matter: https://slack-status.com/2025-07/1ce16e396a56dcf8

Slack is currently recommend that users continue trying to refresh their client using Command + Shift + R (Mac) or Ctrl + Shift + R (Windows/Linux).
Posted Jul 15, 2025 - 11:57 PDT

Update

We are still seeing reports of select and multi-select menus failing to populate due to an issue with certain versions of the Web and Desktop Slack client.

The following platforms are unaffected:
- Rootly Web Dashboard
- Slack iOS/Android app

On-call paging is not impacted.
Posted Jul 15, 2025 - 11:39 PDT

Investigating

We are seeing multiple reports that Slack Client Version 4.45.60
5ceb15a480a45f9ff66f8ac70ad43d9365eda8e6@1752518552 (Production) has re-introduced the same issue with select menus and dropdowns from earlier noted here: https://slack-status.com/2025-07/1ce16e396a56dcf8

We are working with Slack to resolve this issue.

As a workaround, in order to create / update an incident you can use our Web Dashboard or Slack iOS / Android app.

We are are monitoring the issue closely with Slack and will update this page when we have more information.

On-call paging is not impacted.
Posted Jul 15, 2025 - 10:34 PDT
This incident affected: Slack App.