Slack Outage (3rd Party) Impacting Rootly Slack App

Incident Report for Rootly Production

Resolved

Error rates have come down significantly. Scattered delays when creating channels. The /rootly command is now working as intended.

Stay up to date with Slack: https://slack-status.com/2025-02/1b757d1d0f444c34.
Posted Feb 26, 2025 - 12:42 PST

Update

Our engineering team is continuing to monitor closely. We've pushed a few changes to modify our retry logic despite Slack API reporting an outage. We are continuing to look for alternative methods.

Stay up to date with Slack: https://slack-status.com/2025-02/1b757d1d0f444c34.
Posted Feb 26, 2025 - 09:04 PST

Update

Latency and failure rates from Slack remain quite high still https://slack-status.com/2025-02/1b757d1d0f444c34.
Posted Feb 26, 2025 - 08:57 PST

Identified

Slack is running into an incident that is impacting /slash commands (e.g. /rootly new) and messaging capabilities https://slack-status.com/2025-02/1b757d1d0f444c34. This means button interactions and messages are delayed or will fail completely. Some users have also reported being unable to load Slack completely.

Rootly On-Call and Web Platform remain unaffected.
Posted Feb 26, 2025 - 08:06 PST
This incident affected: Rootly Slack App.